IntelliShift - Users Not able to Sign In
Incident Report for IntelliShift Public
Postmortem

The IntelliShift product experienced system wide performance issues that impacted all users on IntelliShift Web & Mobile Applications during this time. Users were unable to access certain aspects of the application, and several users received errors upon login. The IntelliShift team understands this is not acceptable as users rely on IntelliShift solutions to be operational to deliver real-time data.

The IntelliShift Product Development & Architecture teams were immediately alerted and worked to find the root case and address the issue immediately. This issue occurred as a result of increased latency and performance degradation on several third-party map, geocoding, and address look up web services that the IntelliShift applications utilize to deliver standard product functionality to users. The increase in response times caused delays in the IntelliShift telematics live feed, which then impacted the performance of other modules in the IntelliShift application environment causing users to receive errors in the IntelliShift application.

The IntelliShift Product Development & Architecture teams worked to address this issue by reviewing all systems logs. After seeing the potential root cause, the team began working with the third-party, while adding other services to reduce the impact of the performance degradation that was occurring on the third-party service. Once stabilized, additional monitoring was added to the service to mitigate the impact this could have in the future.

To prevent issue from impacting IntelliShift users in the future, the IntelliShift Product Development & Architecture have added additional services to augment the existing service to reduce the reliance on these services going forward.

Posted Oct 15, 2022 - 15:11 EDT

Resolved
At this time users trying to sign in to IntelliShift should be able to sign in without issue. We are working to draft the root cause analysis to this issue.

Thank You.
Posted Sep 20, 2022 - 14:04 EDT
Investigating
We have started to receive reports that users are getting presented with a white screen when signing in to IntelliShift. This issue is preventing users from accessing the IntelliShift platform.

Our team is actively engaged on this at this time and we are working to identify and resolve the issue.

Thank You.
Posted Sep 20, 2022 - 13:41 EDT
This incident affected: IntelliShift Application.