IntelliShift - Telematics live feed delay.
Incident Report for IntelliShift Public
Resolved
This incident has been resolved and the IntelliShift Telematics live feed has been restored.
Posted Jan 03, 2023 - 10:30 EST
Investigating
As of 9:45am Eastern IntelliShift Telematics is experiencing a delay of the live feed.

Our team is investigating the issue and are working to resolve this issue as soon as possible.

During this time Map View - Live Tracking and Reports may be delayed.
Posted Jan 03, 2023 - 09:58 EST
This incident affected: IntelliShift Application.