IntelliShift Application Not Accessible

Incident Report for IntelliShift Public

Resolved

The Intellishift platform is back online and users are able to sign in.

Thank you for your patience on this.

We are continuing to monitor the situation.

Regards
Posted Sep 04, 2025 - 11:52 EDT

Investigating

At this time we are seeing users receiving an error that “something went wrong. Please try again” and preventing users from loading the platform.

The Intellishift team is engaged and working to resolve this issue as quickly as possible

Thank you
Posted Sep 04, 2025 - 11:38 EDT
This incident affected: Web Application.