Telematics Map and Fleet Status Loading

Incident Report for IntelliShift Public

Resolved

This incident has been resolved. Our teams are continuing to review this incident to ensure we implement a permanent solution to prevent this from recurring.
Posted Mar 24, 2025 - 15:50 EDT

Investigating

At this time we have received reports from users who are experiencing issues with Assets Not Loading on the Telematics Map View and Fleet Status screens.
Posted Mar 24, 2025 - 15:28 EDT
This incident affected: Telematics and GPS location and Mobile App.