IntelliShift - Telematics Live Feed Delay.
Incident Report for IntelliShift Public
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 15:51 EDT
Investigating
As of 2:30pm Eastern IntelliShift Telematics is experiencing a delay of the live feed.

Our team is investigating the issue and are working to resolve this issue as soon as possible.

During this time Map View - Live Tracking and Reports may be delayed.
Posted Jul 14, 2023 - 14:46 EDT
This incident affected: IntelliShift Application.