IntelliShift Hours of Service Issue

Incident Report for IntelliShift Public

Resolved

This incident has been resolved though our team is monitoring this closely

Thank You.
Posted Jun 20, 2025 - 10:55 EDT

Identified

Our team has identified an issue loading Hours of Service on the IntelliShift platform, our team is engaged on this and working to resolve this issue as soon as possible.

Thank you for your patience.
Posted Jun 20, 2025 - 09:39 EDT
This incident affected: HOS / Logbook.